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Abstract

In this tutorial we will build and simulate a CMOS inverter using Virtuoso Schematic Com-
poser and Spectre. The inverter will be characterized using Transient, AC, and DC Analysis.
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1 Library and Cell Creation

1.1 Creating Libraries

Launch Cadence Virtuoso (refer to the previous tutorial if needed). You should see two windows:
The CIW with a title of “Virtuoso R©6.1.x” and the library manager with a title of “Library Man-
ager”. Each time you want to start a new project (not a cell) you should create a new library
and attach the created library to certain technology node. The technology we will be using is On
Semi C5 (0.50 micron) previously known as AMI. Therefore, to create a new library:

• Go to the Library Manager’s menu File⇒ New⇒ Library

• In “Name” textbox type ECE412 then hit OK

• You will be asked to choose a Technology file for the new library. Select “Attach to an existing
technology library” as seen in figure 1 then hit OK

• Select “NCSU TechLib ami06” as shown in figure 2 then OK.
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Figure 1: Technology File for New Library

Figure 2: Attaching Technology Library

Now you should see the library you created in the list, any cell created inside this library
will use the same technology node, therefore, If you fail to attach the correct technology to your
library none of the simulations we will perform next will work. To know what kind of technology
is attached to certain library just right click the library name (e.g. ECE412) then Properties the
“Library Property Editor” should contain techLibName = “NCSU TechLib ami06” as shown
in figure 3.

Figure 3: Library Property Editor

1.2 Creating Cells

We will use the same library we created in section 1.1 for all cells (e.g. Inverters, Op Amps, NAND
gates, etc) we’re going to simulate using On Semi 0.50 micron technology. For simplicity the CMOS
inverter will be demonstrated in this tutorial. To create an inverter:
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• Select and Highlight the library you created in section 1.1 e.g. (ECE412)

• Go to the Library Manager’s menu File⇒ New⇒ Cell View

• A Pop-up window appears titled “New File” as shown in figure 4. In the “Cell” textbox type
inv .

• Make sure that the “View” and “Type” are set to schematic. Hit OK.

Figure 4: Creating a new Cell View

A new blank editor should appear in front of you. You are encouraged to familiarize your self with
the interface, just move your mouse cursor over the menu and check out what they do. Also, it is
a good habit to remember the keyboard shortcuts associated with this editor, just go to the menu
on top and look for any letter beside it e.g. if you go to Create⇒ Instant⇒ Cell View You will
notice the letter “I” beside it, hence, if you just hit “i” on the keyboard you can create an instance
quickly. The more you use these shortcuts the faster your design process will be.

1.2.1 Adding Components

To create an inverter we need to instantiate four components: VDD, GND, NMOS Transistor,
and PMOS Transistor. Once you create an instance two pop-up windows will appear “Component
Browser” shown in figure 5 and “Add Instance”. Using the Component Browser window select
“NCSU Analog Parts” for “Library” then click on “N Transistors” in the component list and click on
“nmos4”. Now move the mouse cursor over the schematic editor and place the transistor anywhere
you like. Repeat the same process for PMOS Transistor and finally for ground and power click on
“Supply Nets” and choose “vdd” and “ground”.
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Figure 5: Component Browser

1.2.2 Wiring it up

Once we have all components on the schematic editor we have to connect them to form a valid
inverter, so, go to Create⇒ Wire⇒ or simply hit “w” on the keyboard and click once on the
Drain of PMOS then click again on the Drain of NMOS. You should see a blue wire connecting
both ends. Repeat the same process for all ends PMOS Source and Bulk to VDD and NMOS
Source and Bulk to GND. Finally we need an input pin and an output pin.

1.2.3 I/Os

For this simple design we need two I/Os an input and an output: go to Create⇒ Pin⇒ or just
“p” type the pin name as IN and select the Direction to be “input” then click on the schematic
editor to place the pin icon anywhere you like. Now wire it up to the gates of the NMOS and PMOS
transistors. Repeat for the output pin; the name is OUT and the Direction is “output” then wire
it up to the Drains of the NMOS and PMOS transistors.

1.2.4 Inverter Schematic

After connecting all wires to the corresponding nodes your inverter should look like figure 6. To
make your schematic fill the editor window hit “f” on the keyboard.
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Figure 6: Inverter Transistor Level Schematic

1.3 Creating Symbols

It is sometimes desired to work with device-level schematic rather than transistor level, therefore, to
create a symbol for the device (Inverter) created in the previous section: go to Create⇒ Cellview⇒
From Cellview a pop-up menu should appear as shown in figure 7a. Everything should be already
filled out, just confirm that “Tool/Data Type” is schematicSymbol then click OK. Next you you
can set the position of each pin as shown in figure 7b this becomes useful for multiple IOs.

(a) Creating a Symbol from Transistor level
Schematic

(b) Generating Symbol IOs and Their Orienta-
tion

Figure 7: Creating An Inverter Symbol
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A generic symbol should appear after acknowledging “Symbol Generation Options”. Now you
can edit the shape to look like an inverter by drawing a triangle and a circle at its tip. To draw a
triangle: go to Create⇒ Shape⇒ Line, when drawing a triangle you have to close the shape in
order to finish it. Drawing a circle is very similar however, you have to go to Create⇒ Shape⇒
Circle then click and release to form the center of the circle and move the mouse pointer outwards
to increase the diameter. An example is shown in figure 8. Finally to save your symbol click on
“Check and Save” of simply “F9” on your keyboard.

Figure 8: Inverter Symbol

2 Simulation

2.1 Test Circuit

There are several methods to test the performance and functionality of a given component. In this
tutorial we won’t use stimulus files, however, we will focus on using Virtuoso Schematic Editor and
Analog Design Environment (ADE) to achieve this task. To build an inverter test circuit open the
“Library Manager”, make sure that the library e.g. ECE412 is highlighted then File⇒ New⇒
Cell view, create a schematic and call it inv test. Now we will use the symbol we created in the
previous section 1.3 as a DUT (Device Under Test):

1. To add the DUT: Create an instance by hitting “i” on the keyboard: For Library choose e.g.
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ECE412 and then select inv then move the mouse cursor over the schematic editor and place
the symbol anywhere you desire.

2. We need a power supply of 5Volts. Therefore, create an instance for analogLib⇒ Sources⇒
Independent⇒ vdc before placing vdc on the schematic editor look for a pop-up window
titled “Add Instance”, this should have appeared when you clicked on vdc, change the “DC
voltage” field to 5 and hit OK. If you cannot find this pop-up window just place vdc anywhere
on the schematic editor, select it, then right click⇒ Properties then change the DC voltage
to 5 and hit OK.

3. To connect the DC voltage source to the inverter’s global supply nets (vdd and gnd) simply
create an instance for vdd and connect it to the positive pin of vdc and gnd to the negative
end

4. The inverter’s input and output pins should be connected depending on what you intend to
characterize. For example, to test the functionality of the inverter we will connect a pulse
generator as an input then plot/display the output of the inverter to verify it manually.

• Add a new instance for analogLib⇒ Sources⇒ Independent⇒ vpulse under “Add
Instance” pop-up window change Voltage1 to 0, Voltage2 to 5, and Period to 1n. Leave
the rest blank and hit OK.

• Place the vpluse on the east of the inverter’s input and connect the positive pin of vpluse
with the input of the inverter.

• The negative pin of vpulse should be connected to ground: We can either wire it to
ground, create an instance for gnd, or copy gnd by hitting “c” on the keyboard then
selecting the gnd component and placing the new copy on the negative pin of vpluse.

• The last remaining pin is the inverter’s output pin we will simply create a pin by hitting
“p” and name it “out test” then wire it to the inverter.

5. Verify that you have a power supply with a valid DC voltage (vdc), a valid input signal
(vpulse), a valid output monitor (pin) e.g. shown in figure 9
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Figure 9: Inverter Test Circuit

You can create as many test circuits as needed. Usually, one would create a test circuit for different
input/output schemes. Most of the time you can use the same circuit to do DC, AC, and transient
response analysis.

2.2 Transient Analysis

One should use transient analysis to find any component/device’s response versus time. First, create
a test circuit as described in section 2.1. If you have already done so, go ahead and open it using
Virtuoso Schematic Editor by double click on inv test in the Library Manager. There are several
ways to do transient analysis, however, we will use ADE GXL to store all simulation data in a
unified location which can be used later with ease:

1. Start ADE GXL from Virtuoso Schematic Composer: Launch⇒ ADE GXL⇒ Create
New View

2. Verify the name of the cell and choose open in new tab then hit OK.

3. A new tab titled Welcome to ADE GXL will appear, by default the left menu should contain
“Data View” as depicted in figure 10
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Figure 10: ADE Default Window

4. Under the “Data View” menu; expand Tests by pressing on the plus sign beside it then click
on “click to add test” a pop-up window will ask select a design. Choose inv test and hit OK.

5. Shown in figure 11 is the ADE test editor where all parameters, models, paths, etc will be
defined. The following settings should be set by default however you need to verify them to
insure a valid simulation:
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Figure 11: ADE Test Editor

• Setup⇒ Simulator verify that spectre is selected in the drop down menu.

• Setup⇒ Model Libraries verify that you have
/opt/soft/ncsu-cdk-1.6.0.beta/MSU/allModels.scs enabled under Global Model
Files.

6. Choose a simulation type: go to Analyses⇒ Choose. For Analysis select “tran” and for
stop time type 20n that is twenty nano-seconds. Refer to figure 12.

Figure 12: Transient Analysis
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7. To plot the input/output response versus time ADE allows the user to select certain wires/nodes
to display. Go to Outputs⇒ To Be Plotted⇒ Select on Schematic. The schematic com-
poser is brought to front, you can now select the desired signals. NOTE:

• Selecting nodes e.g. red boxes will plot currents. When selected the node
will be circled.

• Selecting wires e.g. blue lines will plot voltages. When selected the line will
appear dashed.

If you accidentally clicked on a node/wire but you don’t want to plot it just click on it again
to remove it. We are interested in plotting the input/output voltages versus time. Therefore,
select the wire connected to the positive terminal of the pulse generator then select the wire
connected to the output pin. The schematic should look like figure 13. When done selecting
outputs press ESC on the keyboard to return to ADE test editor.

Figure 13: Select output to be plotted from schematic

8. Your simulation environment is ready now and it should look like figure 14.
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Figure 14: ADE XL Test Editor with new settings

When done you can close the ADE Test editor and return to AGXL which looks like figure 15.
Note that all the options we set in the ADE test editor now appear on the left hand menu.

Figure 15: ADE GXL with new settings

9. Start the simulation by clicking on the green play icon or go to Run⇒ Single Run, Sweeps,
and Corners. The result plots should appear in front of you as shown in figure 16. In case
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you do not see any results, go to the results tab and click on “Plot All”. To plot the two
graphs on two individual axises; go to Axis and check Strips.

Figure 16: Transient response with two different axises

2.3 DC Analysis

We will follow the same procedure explained in section 2.2. We can utilize the same simulation
environment created in the previous section, however, we need to add a new type of analysis:

1. Disable transient analysis under the ADE GXL window, Data View, ECE412:inv test:1 and
remove the check box beside “tran” to disable the previous simulation.

2. Create a new analysis by clicking on “Click to add analysis” in gray. If you do not see it make
sure you explain the test by clicking on the “+” sign.

3. Choosing Analysis window pops-up. Under analysis select “dc” and check “Save DC Op-
erating Point”. Under Sweep Variable check “Component Parameter” then click on “Select
Component”. The schematic composer should appear, click on the voltage pulse generator.
Finally, a small pop-up window titled “Select Component Parameter” appears: Click on DC
VDC “DC Voltage”. Both windows are shown in the figure 17 below.

4. For Sweep range start at 0 volts and end at 5 volts. Make sure that the analysis is enabled
then click on OK.

5. Start the simulation by clicking on the green play button. The output should look like
figure 18. We need to calculate the crossing point between the input and the output. This
point will be used later in AC analysis.
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(a) Choosing Analysis window to select DC and
component

(b) Selection of component parameters

Figure 17: Pictures of animals
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Figure 18: Inveter DC analysis

6. The crossing point can be either estimated using the mouse by hovering over the crossing point
or calculated using Virtuoso Calculator. In the graph window go to Tools⇒ Calculator.

7. After launching the calculator look at the bottom half of the window near Special functions
and look for “cross”. Now click on “cross” you should see an integrated input box where the
cursor is blinking in “Signal” text box.

8. We need to type a name of a signal or select a waveform from the graph window. To select
a waveform from the graph window click on “Wave” in the upper half of the calculator (near
Family) then go to the graph window and click on “test out” (the waveform itself or the label
both would work). The “Signal” textbox should have “wave xx()” or “v(/out test ?result
dc-dc)”. Leave the threshold and edge number and type the same then hit OK.

9. The calculator’s buffer text area should have the cross() function with the proper parameters.
Click on evaluate buffer as depicted in figure 19 and write down the result, we will use it later
in AC analysis. You can now close the calculator and the graph window.
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Figure 19: Virtuoso Calculator

2.4 AC Analysis

We will follow the same procedure executed in the previous two sections. The only difference here
is that the test input has to be change to an AC source.

1. Go to the schematic composer and click on the voltage pulse generator then hit “q” on the
keyboard. The proper window should pop-up.

2. Change the Cell name from “vpulse” to vsin then click on apply. Now modify AC magnitude
to 1, AC phase to 0, and DC offset to the crossing value we computed using the calculator in
section 2.3. The proper window will look like figure 20.

3. Save the schematic, by clicking on the Check and Save icon.
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Figure 20: AC input source

4. On the left side menu add a new test. For Analysis select “ac”, Sweep Variable select “Fre-
quency”, and Sweep range: start at 10 and stop at 1G with a sweeping type of Logarithmic
and 10 points per decade. Enable it and hit OK. This is shown in figure 21.

Figure 21: AC analysis properties

5. Under Data View: Disable all other analyses and make sure that “ac” is checked. Start the
simulation. If the plots do not appear go to adexl tab then Results and click on “Plot All”.
The simulation result will look like figure 22.
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Figure 22: AC analysis for an inverter

6. To plot the 20dB Magnitude and Phase. Go to adexl tab then Results and right click on
“/out test” Direct Plot⇒ AC Magnitude Phase. The graph is depicted in figure 23.
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Figure 23: 20dB Magnitude and Phase
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